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Visualizing molecular simulations ChE210D 

Overview 
Visualization plays a very important role in molecular simulations: it enables us to develop 

physical intuition about the behavior of a system that is difficult to discern from simple averages 

and distributions alone.  It is often through a visual analysis of a system that one formulates 

mechanistic ideas and driving forces about processes.  Once these ideas are formulated, one can 

go back and develop quantitative metrics (through simulation averages and distributions) that 

are designed to measure the observed behavior.  Visualization is also a key component of 

debugging.  If a simulation isn’t running properly, you should always visualize it first! 

This tutorial describes how to visualize and make a movie of a molecular simulation using the 

freely available program UCSF Chimera.  Chimera comes preloaded with many helpful tools for 

analyzing results and making movie files from trajectories.  To make a movie, you will also need 

to download a script for writing trajectory files that Chimera can read.  This script can easily be 

incorporated into your Python simulation code, and is available on the course website. 

Installation 
To install Chimera, download the latest production release at 

https://www.cgl.ucsf.edu/chimera/ 

Executable install files for Mac OS, Windows, and Linux are available.  In this example, we will 

only describe the very basic steps needed to make a movie.  However, extensive documentation 

and tutorials for accomplishing many tasks in Chimera are provided at: 

https://www.cgl.ucsf.edu/chimera/docindex.html 

You will also need a script to produce trajectory files from your simulations called atomwrite.py.  

This script can be downloaded from the course website. 

Alternative visualization software 
There are many freely available packages for visualizing molecular systems.  UCSF Chimera is 

perhaps the most complete in terms of coming pre-loaded with many movie-making and other 

utilities.  However, other packages may offer benefits for particular tasks.  The list below 

describes three popular ones, although there are many more, including commercial packages: 
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package website notes 

Pymol http://www.pymol.org/ Somewhat steep learning curve, but many 
capabilities, particularly for protein structures. 
Python integration for writing scripts.  Very nice, 
publication-quality, ray-traced images produced.  
Used to be more widely used until purchased by 
Schrodinger and now compiled releases require 
license purchases. 

VMD http://www.ks.uiuc.edu/R
esearch/vmd/ 

Many plug-ins available.  Works well with trajectories 
and accepts many formats.  Integrates with the MD 
package NAMD. 

Discovery 
Studio 
Visualizer 

https://www.3dsbiovia.co
m/products/collaborative-
science/biovia-discovery-
studio/visualization-
download.php 

Commercial software for molecular modeling with 
particularly user friendly functions, especially for 
editing and preparing initial structures for modelling 
programs.   

UCSF 
ChimeraX 

https://www.cgl.ucsf.edu/
chimerax/ 

This is a newer and more modern version of 
ChimeraX, with a slicker user interface and the ability 
to render more realistic and impressive images.  
However, not all of the features of the old Chimera 
are yet fully incorporated into ChimeraX. 

Saving a trajectory during a simulation 
A trajectory file contains a list of frames.  Each frame corresponds to a list of coordinates of all of 

the atoms present.  There are many formats for molecular simulation trajectories.  Here we will 

consider a very simple format: a .pdb file with multiple coordinate sets (“models”).  This format 

is not very efficient in space usage, but it can be read by many different visualization programs. 

To write a pdb trajectory, you need to load the atomwrite.py module in your simulation code: 

import atomwrite 

At the beginning of your simulation, you can open a pdb file using a custom function in that 

library: 

Pdb = atomwrite.pdbfile(“anim.pdb”, L) 

Here, the variable L gives the box length.  It can be a scalar (for a cubic box) or a vector of length 

three (for a non-cubic box).  Alternatively, it can be omitted altogether if you do not desire 

minimum-imaging: 

Pdb = atomwrite.pdbfile(“anim.pdb”) 
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The variable Pdb is now an object that has methods similar to a file object in Python.  Periodically 

during your simulation, you want to write the current (N,3) position array to the trajectory: 

Pdb.write(Pos) 

Note: distances should be in units of Angstroms or in dimensionless units. 

You do not want to output a frame at every step, since this will make your trajectory huge, slow 

the performance of your simulation, and result in very slow-paced movies.  Instead, choose a 

frequency to write frames.  A typical frequency might be every 100-200 integration steps in an 

MD trajectory: 

PdbFreq = 100 

…  

if StepNum % PdbFreq == 0: 

    Pdb.write(Pos) 

At the end of your simulation you want to close the pdb file: 

Pdb.close() 

After you have run your simulation, you should see a .pdb file produced with the name you gave 

it.  By default, this script will write to a compressed file in gzip format.  In the above example, we 

would expect to find the file “anim.pdb.gz”.  The script writes to a gzipped file to save storage 

space and because Chimera can read these directly (without prior decompression). 

If you want to override writing to a compressed file, and instead want to write directly to an 

uncompressed file, use the opening statement 

Pdb = atomwrite.pdbfile(“anim.pdb”, Compressed = False) 

Atom names 
When you later import your trajectory into Chimera, you will need to select atoms by their type 

to make changes to them.  If you want to modify the color or size of certain atoms, you will need 

to be able to select only those atoms.  To enable this, you want to give those atoms a different 

name than the others.  You can do this by assigning dummy elements to different atom types in 

your simulation.  By default, the atomwrite script give all atoms the name of ‘C’, for the element 

carbon, unless you specify the names explicitly.   

To specify atom names in the pdb output, send the opening statement a list of string names of 

the atoms: 

Names = [‘C’, ‘C’, ‘C’, ‘O’, ‘O’, ‘O’, ‘N’, ‘N’, ‘H’, ‘H’, ‘H’, ‘H’] 

Pdb = atomwrite.pdbfile(“anim.pdb”, L, AtomNames = Names) 
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The length of the Names array should be the same size as the number of atoms.  This example 

assumes 12 atoms are present. 

Outputting a single configuration 
If you want to examine a single, static configuration, simply call the Pdb.write function a single 

time before closing the file.  As a shortcut, 

atomwrite.pdbfile(“anim.pdb”, L).write(Pos) 

This statement automatically creates the object, writes Pos, and closes the file. 

Starting Chimera and importing your trajectory 
Once you have outputted your positions, you are ready to import your trajectory into Chimera.  

Start the Chimera program.  The first time, this may require a small amount of time due to the 

initialization routines. 

Once the Chimera window is open, go to Tools > MD / Ensemble Analysis > MD Movie: 

 

A small additional window should appear: 
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Make the following selections: 

• Choose PDB for trajectory format. 

• Choose “single file”. 

• Browse to select your trajectory file produced by your simulation. 

Then hit OK.  Chimera should load your trajectory and produce the following new window in 

addition to the main window: 

 

Don’t close the MD Movie window until you are completely finished with your trajectory.  Closing 

this window will unload your open trajectory. 

The main window should now contain many little dots or spheres, which correspond to the 

positions of the atoms.  In may also contain some lines, like the one seen above.  The dots 
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correspond to atom centers and the lines correspond to any bonds.  By default, Chimera tries to 

automatically assign bonds based on interatomic distances.  If your system is built from coarse-

grained or simple Lennard-Jones atoms, you will want to get rid of these bonds.  We discuss how 

to do this below. 

We want to change the representation of atoms from dots to spheres.  To do this, go to Actions 

> Atoms/Bonds > sphere. 

 

You should now see something like this: 
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There are many different representations of atoms that you can use, as might be evident from 

the menu above.  If the spheres are too big, you can adjust their radii.  Instructions are below. 

Interacting with the Chimera display 
You can rotate, translate, and resize the display by clicking on it: 

• To rotate the system about the x and y axes, click near the center of the window and drag 

with your mouse, staying close to the center of the molecule. 

• To rotate the system about the z axis, click near the edge of the window in the black 

background and drag around the outside of the window. 

• To zoom in or out, use the scroll button on the mouse.  Alternately, click with the right 

mouse button and drag. 

• To translate the system in the x and y directions, click the scroll button or the middle 

mouse button (if you have one) and drag. 

To animate your movie, click the play buttons in the MD Movie window. 

 

Adjust your trajectory to a view that you like.  This will ultimately be the view encoded in the 

movie. 

Deleting bonds 
If Chimera automatically assigned bonds to your atoms, you will likely want to delete these.  To 

do so,  

• Go to Select > Select All. 

• Then, go to Tools > Structure Editing > Build Structure. 
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• Select Adjust Bonds at the top. 

You should see something like: 

 

Click Delete and your bonds should be gone.  Click close to exit this window. 

Selecting atoms 
In what follows, we will describe methods for changing the color and size of atoms.  You can apply 

these changes to all atoms in the system, or to specific atoms of your choosing. 

To select all atoms, go to Select > Select All. 

To select atoms of a specific element, go to Select > Chemistry > element and then choose the 

desired element.  The elements in your trajectory will correspond to the names you specified in 

the AtomNames option of the atomwrite.pdbfile call that you made earlier.  
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By default, selections in Chimera are additive.  That is, if you make multiple selections in a serial 

order, the final selection will be the union of all of these.   

To clear the selection at any point in time, go to Select > Clear Selection. 

You can also select specific atoms using the mouse: 

• Hold the Ctrl key and click on an atom to select it. 

• To select multiple atoms this way, hold down both Ctrl and Shift when clicking. 

• To clear the selection, hold down the Ctrl key and click in the background space. 

Changing the color of selected atoms 
To change the color of your selection, go to Actions > Color and choose the desired color.  The 

“all colors” option will bring up a wider palette of colors from which to choose. 
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Changing the size and other properties of selected atoms 
The inspector is a menu that contains options that you can tweak for any selection that you make.  

Once you have made a selection using the above procedure, you can bring it up by clicking the 

green button at the bottom right-hand side of the main Chimera window.  

 

Clicking on this will open the inspector window: 
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To change the size of the selected atoms, edit the “radius” box and hit Enter afterwards. 

By default the radii are taken from the van der Waals radii for the elements (atoms are assumed 

to be carbons if you have not specified otherwise).  You will want to change the radii to be 

commensurate with the length scales in your system.  For example, for a Lennard-Jones system 

in dimensionless units, you will want to change the radius to a value of 1. 

You can close the inspector box when you are finished making your change. 

Changing the background color 
Oftentimes black backgrounds can result in very dark movies that are difficult to see when one is 

giving a presentation to a large audience.  In such cases, a white background helps.   

To change the color of the background, go to Favorites > Preferences.  On the menu that appears, 

go to Category > Background: 
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Click on the button to the right of Background color.  Another window should appear.  Check the 

Opacity box and make sure the other settings are as follows: 

 

Close out these two dialogs when you are finished. 

Making movies from trajectories 
When you have edited the visual display to your liking, you will want to create a playable movie 

file (.avi, .mpg, or .mov) from your trajectory.  Before doing so, you should use the play button 

on the MD Movie dialog to ensure everything is to your liking. 

First, adjust the size of the Chimera main window to be the size and dimensions that you want 

your movie file to be.  The movie tools will take the dimensions (in pixels) directly from the main 

window when making your movie file.  Keep in mind that larger sizes result in larger files. 

Then, in the MD Movie window, go to File > Record Movie.  The following window should appear: 
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There are many options here.  We will go through them in sequence: 

• Select a path in which to store your movie file from the directory locator at the top of the 

dialog. 

• Enter a file name of your movie file below that. 

• Choose a file type.  For Mac systems, you can select the Quicktime format.  For Windows 

systems, one can choose the AVI-MSMPEG-4v2 format.  On the other hand, the MPEG-2 

format works reasonably well on a wide variety of systems.  This is what we will use here. 

• The starting and ending frames can be set if you do not wish to record your entire movie.  

You can determine at what frame numbers to start and end by viewing the movie with 

the MD Movie play button. 
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• The Step size box tells Chimera to use only those frames every n steps.  If you make a 

movie and find that its pace is too slow, you may want to re-make it with a larger step 

size.  By default, your movie file will play at a rate of 25 frames per second. 

• “Encode forward and backward” and “Frame quality” can generally be left to the defaults 

shown above.  Changing these can sometimes result in slightly better-looking movies. 

• If you want a very nice-looking, high-quality result, you can have each frame image 

generated with a ray-tracing program that will produce visually attractive three-

dimensional images.  To do so, set Rendering to use Pov-Ray.  This will require a longer 

movie compilation time, but the resulting movies will be more impressive.  Generally you 

should only select this option once you have made a “draft” non-raytraced movie file and 

have found all settings to your liking. 

• There are a number of options that can be included in the “Additional encoding options” 

box to adjust the quality and parameters of the output movie file.  The only one we will 

discuss here is the bitrate option.  This controls the size and quality of your movie file.  

Higher bitrates result in larger files, but have much better visual quality.  The command 

“bitrate 5000” will produce a higher quality movie than the default, which is 2000 

 

Once you are done with settings and options, hit Record.  Depending on the length of your 

trajectory and the settings you used, this may take several minutes to an hour.  For raytraced 

movies, this can take even longer.  When you are done, you can open your movie with any of the 

popular movie viewers (Windows Media Player, Quicktime) and you can also insert your movies 

into presentations. 

Making movies from interactive changes 
You can also make a movie from any actions you perform in the Chimera display, including 

rotating, translating, zooming the display, changing sizes and colors, and playing, pausing, and 

reversing a trajectory.  This approach is very similar to macro recording in programs like Excel or 

Word.   

To begin, we want to open the Movie Recorder window.  Go to Tools > Utilities > Movie Recorder.   
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You need to set options in this dialog box before beginning to record your movie.   

• Choose a file name for your movie file in the “Output file” dialog.  You will need to use a 

file name extension that corresponds with the format you selected in Movie Preferences. 

• As before, you can choose the format of your movie in “Output format”. 

If you expand Frame Options and Movie Options, you can customize the properties of the movie 

file that will be made.   

• You can adjust the quality of your movie by changing the “Quality” category.   

• Alternately, you can change the playback bit rate to “constant” and then explicitly specify 

the bit rate of your movie in the “Constant bit rate” section.  A reasonable value for high-

quality movies is 5000.   

• You can use raytracing with this utility if you desire higher-quality 3D images, using the 

Rendering option, but this will require much increased compression time. 

Now, adjust the size of the Chimera main window to be the size and dimensions that you want 

your movie file to be.  The Movie Recorder tool will take image frames directly from this window. 

You can begin recording your interactions with the movie window by hitting the button Record.  

At this point, Chimera will begin recording movie frames in real time.  Any interactions you have 
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with the Chimera window will be recorded in your movie.  The mouse pointer, however, will not 

be recorded.  The rate at which you can record frames may be limited by your computer 

hardware. 

When you are recording, the Record button changes to Stop.  You can pause recording at any 

time by hitting the Stop button. This doesn’t reset your movie, but rather, simply pauses it; 

Chimera will begin recording again if you hit Record a second time.  Using this process, you can 

make changes as needed in between records that will appear as instantaneous changes in your 

movie. 

You can also record a trajectory this way: click Record on the Movie Recorder window and then 

hit Play on the MD Movie window.  You can play forwards or backwards, or adjust the rate at 

which the movie plays by changing the speed bar or step size.  Some trial-and-error might be 

needed to get a good feel for settings that will look good. 

If at any time you want to dump (clear) all of the frames so far recorded, click the Reset button. 

Once you are done recording (perhaps in stages, with intermediate pauses), you need to convert 

the saved frames into a movie file.  MD Recorder should be stopped.  Then, press the Make Movie 

button and your frames should be assembled into the movie filename and format that you 

specified.  It’s that simple! 

Making movies from scripts 
All commands in Chimera can be implemented as scripts using Chimera’s own command 

language or using Python, which Chimera has built-in.  A predefined set of camera movements 

can thus be scripted and a movie can be recorded from them.  This is the ideal way to make 

movies that involve extensive camera movements, as the motions can be made very smooth and 

to have exact timings.  We will not cover this in detail, but extensive documentation and tutorials 

are available on the Chimera website: 

http://www.rbvi.ucsf.edu/chimera/docs/ContributedSoftware/movie/framemovie.html 


